RDWorks - can't open it's own saved files?


#21

I’m checking with the Team on Discord.
Previous download links would generate a virus alert.
So the older version we use, we know is OK.
Did you get a virus alert on your recent upgrade?


#22

Nope, downloaded no issue.


#23

That’s usually because the new version hasn’t been seen enough in the wild to be trustworthy.

Just to be clear, the newer versions start up but just throw the error when you open a file?


#24

We have the older version at DMS, when creating a file at home on the newer version it won’t at DMS on the older version.


#25

We now have the .19 newer version installed on all 3 Thunder Laser computers. I’ve opened files created in the older version and files created on the newer version. I’ve logged out and back in and the old and new files open fine.

@motopilot
The only issue I’m having now is with the rdworks login script on Big Thunder. Something about the script causes rdworks to fail with a dll error. For now, I’ve disabled the script by renaming the script folder. Maybe Clay can work some magic with his script when he has a chance. Otherwise I can try to go back to the older version on Big Thunder.


#26

I was wondering if you ever came up with a solution to this problem . I have the same issue I’ve tried downloading for the current version as well as getting versions 18 and 19 off the committee drive and all of them did the same thing you can create a file but once you save it you can’t reopening it without getting the file format error. With the current version 21 I can reopen them on the computer using Windows 10 but I can’t use it the files on the maker space computer which have version 18 . I’ve tried using three different computers as well as three different versions of Windows and none of them work

Jeff


#27

I think the issue cleared for a time due to an upgrade at the space however I think it may be back, my GF reported having the issue again this past week. It’s hard to stay in sync.


#28

Downloaded RDWorks at home again and it seems the version is up to 1.34 now. Anyone else still receive the “File Format error! Please check file version”?

Thanks


#29

Yes. Yes I do. Even when the file was created on the Blitzen computer, untouched on any other computer, then reloaded on the Blitzen computer.

If I can, I plan to attend the next Laser Committee meeting to lobby (fight) for at least one Laser computer to be upgraded. In case I can’t make it a backup would be welcome. :wink:


#30

I had the error before but it was resolved when all the software was updated to version 1.19 from 1.18. I got a new computer and so with each download of the latest/newer rdworks I seem to have this issue. I’m going to look and see if I can find a copy of the 1.19 version now.


#31

THIS ^^. So much this.

May this Chair Emeritus also add the word “work” and a shameless plug? The Committee (any committee, really) needs members to participate at all levels (fixing, upgrading, teaching, cleaning, leading, learning) in order for the Area to run like a top. Please, everyone/anyone, do fall in love with an Area and participate. Team Laser is very accessible and we welcome all.


#32

#33

Using version x.x.19 is currently the solution to most of these problems… Not all… As @jast points out, I put copies on the committee network drive.

I do suggest @Team_Laser upgrade the 3 laser computers, 3 design computers, and jump server to the latest version.


#34

I was just at Blitzen, I believe. The one with the RFID reader. I ran through a series of tests. I was using RDWorks v8.0.1.19 as listed in the “Help->About RDCAM” window.

  • Logged in to the computer.
  • Launched RDWorks.
  • Imported a DXF.
  • Modified some layer attributes.
  • Saved the RLD file.
  • Quit RDWorks.
  • Launched RDWorks.
  • Attempted to open the recently saved RLD file.
  • Error message: “File Format error! Please check file version”
  • Quit RDWorks.
  • Reboot Computer.
  • Login to Computer.
  • Launch RDWorks.
  • Attempted to open the previous RLD file.
  • Error message: “File Format error! Please check file version”
  • Give up.

This makes using RDWorks (and the laser cutters for most of us) suitable for only very simple designs. If you can’t save the RLD and bring it up, you cannot save the layer information, AFAIK.

For example, I am trying to create a calibration job that I can use to select the best power/speed ratio for the material that I have. It uses all 20 layers available in RDWorks. If I cannot open a previously saved RLD file, then I am forced to import it from DXF every time. If I do, all 20 layers are not set at the right speed/power and I would be forced to set them manually every time I run the job.

So far, I have not had any such issues on my home computer that I am running RDWorks 8.0.1.34 on.

Recommendation, update the three computers in the laser lab to RDWorks 8.0.1.34. Test using the above procedure. I concede that the save/open issues could be related to multi-user login or other DMS specific details that I don’t have to worry about on my home computer.


#35

I think the plan is to look at upgrading to the latest version of rd works on Sunday at maintenance day. Thank you for investigating this.

Jw


#36

Thanks. I’ll be there at the maintenance day learning stuff and killing time while my wife is in the Woodshop 101 class.


#37

FYI: We’re in Purple Classroom from 11-noon for the meeting portion…bring your input!
Then we move to Laser for maintenance.


#38

Any update on this? The jump server version is still V8.01.18. I’ve only ever created files logged in on the jump server or modified on the laser computers. Moments ago I created a file remoted in to the jump server, saved it, and now I cannot open it again. I’m able to open a few of my older files, but not all.

Luckily it’s a simple setup, but I hate to tie up a laser computer doing something I could do remotely :slight_smile:


#39

I apologize. I forgot about the administrator / manifest problem so RDWorks was not upgraded.

The solution for the next attempt is here…
https://talk.dallasmakerspace.org/t/13-november-2018-different-versions-of-rdworks-on-jump-server-vs-laser-computers/46274/4?u=brian


#40

Thought I would tell folks how I fixed this issue. It involves the use of regedit so proceed with caution.

  1. Uninstall RDWorks and then delete the RDWorksV8 folder
  2. Go to the search line in bottom left corner of Windows desktop and type in “create a restore point”
  3. Create a restore point in case something goes wrong with regedit. This will enable you to recover if you mess up
  4. After creating the restore point, go to search line and type in “regedit”. Run regedit as administrator.
  5. Using the menu item Edit/Find, search for “RDWorks”.
  6. Delete all entries in the registry that contain “RDWorks”
  7. Exit regedit and reboot your PC
  8. Install new version of RDWorks.

This worked for me, I can now save and reopen files.