RDWorks - can't open it's own saved files?


#1

Seeing strange behavior, hoping someone can provide some insight.

Situation 1) I create a file in RDWorks on my Mac or PC at home and save it to my member drive. It will not open in RDWorks, it says the file is bad.

Even more perplexing,

Situation 2) if I create a file on a laser workstation, save it, then try and open it again I also get the same error.


#2

I miss @LightBurn


#3

Are they the same version?


#4

At first glance, this is either a version conflict issue or the PC needs to be rebooted.


#5

I’ll try rebooting later today.

Home vs DMS PC is one . release off however if I create the file on the DMS PC, save it, and it still doesn’t open that points to something other than a version mismatch going on for me at least.


#6

@jphelps
Be certain your version is from Thunder Laser or our copy on the network committee drive. There are other versions used by other Chinese companies, often with the same version number.


#7

We’re using the version downloaded from Thunder.

I rebooted the DMS workstation and tried again, same result. Can someone else try this procedure and see if it fails/works for them?

  1. Open RDWorks on a DMS Laser workstation
  2. Create a new file with a simple operation (like a square cut)
  3. Save as - RDWorks
  4. close and reopen RDWorks
  5. Attempt to open your file

This test case always produces an invalid file format error for me.


#8

I’ll be there later​. Will run the test.


#9

@Scott_Blevins and I ran those 5 steps.
No error occurred.
All was well.
If you would like to load your file to your Member drive, I can test that, too.


#10

Which thunder laser did everyone try?


#11

Tested all three. Big Thunder, Donner, Blitzen.


#12

With regard to running the 5 step test case in Jay’s message, we tested all three Thunder lasers with the same successful result.


#13

May I suggest coming to Laser Office Hours on Wednesday or the Laser Work Day next Sunday?

It may be obvious if someone else can watch you reproduce the error.


#14

@jphelps Which version are you running?

Catherine installed from Thunder Laser. She has the same issue. Her version is v8.0.19. She cannot open her files on our machines.

We are on v8.0.18.


#15

Another option is to send two simple files to me: one from a DMS version of RDWorks and one from a “not working” version. I have an aptitude for diffing files.


#16

image

I installed the new version of RDWorks on my laptop. it’s v8.0.19.

I receive the following error message when I try to open it on the jump server, which is running v8.0.18


#17

I can open version 8.0.18 files in v8.0.19. I suggest upgrading at least one laser for testing on Sunday at the Maint meeting or before.

@Brian Thanks Brian. Do you still want the files?


#18

If you have questions that could be answering by comparing the files then feel free to send them.


#19

This points to something wrong with specific user profiles. How did you log in for the testing? With individual user accounts and a domain backed profile or something like local admin?

@StanSimmons, any thoughts?

Nothing to compare for my example test case. The file is created on the same machine that won’t then re-open it.


#20

Have any of the machine been upgraded to V8.0.19? That is also what I downloaded from Thunder and my files would not open on the big Thunder yesterday.