CNC 'connecting to host'

Came in today to try and use the CNC. Got through the setup process and tried to load my GCode but when I try to connect to the server to get my file the terminal just says “Connecting to host” and doesn’t actually connect.
Does anyone have any solutions for this?

SOLVED: It seems that restarting the CNC fixed the problem?

In the past the solution is to log into the jump server and restart the multicam. Something about the multicam file host software only running when people are logged in to jump server, so if no one’s logged in the host stops.


I restarted the cnc and it seems like it’s fixed now. Thanks!

1 Like

I’m having this problem now too, and no amount of voodoo i throw at it is fixing the problem. The problem started just after I successfully finished one job and had set up to do a second one.

I’ve rebooted the Multicam from the pendant (Menu–>Utility–>Reboot). I’ve shutdown Machine Tools, and Connection Manager and restarted them multiple times. I’ve checked to maker sure that there are no other instances of either of them running on theJump Server, and there aren’t. The Connection Manager shows the Multicam to be online but not connected. The Job Name Server is crashing with an error that goes by too fast to save. (From what I can catch as the error goes by, I think it has something to do with the connection problem.) Finally, I shut the Multicam down completely, turned it off, and restarted it. No change. Ugh.

I found the Job Name Server log file:

[2020-09-14 19:04:32] JobNameServer.exe 4.6.301.0

XCI Load Failed. Could not find file c:\programdata\machine tools suite 4.0\connections.xci

[10] - Failed to load XCI file

[2020-09-14 19:04:32] JobNameServer.exe 4.6.301.0

[13] - Error(s) occured while trying to create the controller output device. Connection name .

XCI file name c:\programdata\machine tools suite 4.0\connections.xci

OEMString .

Neti .

Finally got it working again, but I need to discuss it with @themitch22 before posting my solution.