Vectric Pro 11 issues

I logged into the computer in woodshop and tried to open Vectric 11 on the computer got this promt to enter license.

This haven’t happend to me before. When Burt logged in to the same computer with his account it opened and worked fine without asking for license.

@jphelps do you have any suggestion?

The way Vectric licensing currently works we have a rule that pushes the license key to that machine’s user registry when you login. If for some reason that didn’t run properly you’d get this error.

I took a look and experienced the same error. I’ll look into it further however it’s Dec 24th and I can’t stay for long.

@SWA I activated windows on the machine and installed some updates that were pending; can’t hurt.
On a related note that’s been discussed previously; that machine is woefully under powered for VCarve Pro in my opinion (Celeron J1800 CPU , 8 GB, Wind 10 Pro) and I’d suggest that the Woodshop prioritize asking the board for a new PC there.


Thanks Jay. How does Vcarve know how many licenses are in use? Is this a quasi floating arrangement?

We specify specific machines in AD that are given the full license.

One other thing you might try, or you could confirm here that you already tried, is reboot the PC and see if you get different results. I noticed Burt was still logged in. I didn’t have time to test this myself, the machine is still updating and is very slow.

We’ve tried again with my account after restarting the computer with the same result. Burt works mine doesn’t.

Do you know when your login stopped working? I don’t use mine on that machine very often.

My last project was more than 2 months ago on the multicam.

Me too, about 2 months, maybe more since I tried my login.

I’ve made a change on the back end, please retry and report your results.

I tried logging in earlier today (two hours ago?) and it was still an issue for me (i.e. I got same gripe screen as in OP). @SWA was able to login directly after me, though.

I made the change when I posted, likely after your attempt earlier today.

1 Like

I came in this morning and spent some time on this. I’ve established that, for reasons I’ve not yet determined, the necessary registry key for the license is not being created for existing or new user profiles on that machine. I tried various changes to the group policy and it’s machine filters to no avail and various testing to sort out some other oddities I uncovered. For instance, Vectric is using a different registry hive for settings now but it can still pick up the license key from the previous location.

I’ll be in tomorrow afternoon to await Atmos and hopefully a return of our gas service to most of the building and will spend some more time on this. Hoping to have it sorted fully at that time.

The machine gets seriously slow if more than one user is logged on. Aside from that it’s not bad. If I show up and someone didn’t log off, I reboot and all is well.

I made some further changes today and did a lot more testing and I think this is working properly now. Please post success or failure here as needed. Thanks!

1 Like

Was able to log in today and open vcarve. Thank you so much for taking time and working on this!