Update on sherline CNC lathe


#1

we’ve gotten the active cable for the lathe and that part at least works. We’re seeing signals to and from the cnc. however - they are in the wrong places. While Mach 4 seems to have a couple of setup pages for ‘mapping’ of signals I have yet to find how to select a signal and map it to a pin. we may have to use a breakout box to physically map the pins. Anyone know if we have such a beast for a parallel port?


#2

Nick, sorry I can’t come in to help, I am recovering from an auto accident. You should not need to change the current port assignments as Mach4 can assign the input and outputs to any pin as needed. There are several good videos on online that will show you how to assign the ports. If all else fails, open up the aluminum control box by removing the 8 screws on the top panel. Carefully lift the top panel off. You will see a circuit board mounted on top of the power supply. This is the C10 parallel interface board. Check the wiring schematic in the system manual. The various port assignments can be changed by moving wires to different terminals strips. Check the C10 manual, also part of the controller manual, as only certain pins can be input and outputs.


#3

Great info Rich. Hope you’re on the mend and feeling better soon.


#4

thank you I’ll check it out. it is not very apparent how to do it.
feel better soon.


#5

Poked around on this just a bit today. I was expecting Mach4 to be loaded on the mobile PC but it didn’t appear to be. I logged in via domain (works), installed Mach4 (installed OK), and started reading the installation guide, etc. I was originally thinking let’s use the parallel port (PP) but that isn’t recommended by Mach anymore, said to be “slow and obsolete”. I know we have the USB adapter but since it translates down to PP it’s really not much different. I ran out of time and wasn’t able to try the USB adapter and I’m not yet clear if we’ll will need the legacy PP plug with that. Looks like we would if we wanted to stick with just straight PP. http://www.machsupport.com/shop/parallel-port-legacy-plugin-for-mach4/

Looks like we will need to scrounge a USB extension, a PP male to male adapter or a new cable with Male and Female ends because the USB adapter is so darn short. A USB extension would probably be best.

Rich came by and we chatted. He had concerns about the yellow PP cable so I tested it in e-lab, pin 2 (data0) was not connected as were others, threw it in the trash bin. Found another PP cable, spot tested OK but as noted above we need to adapt a bit somewhere for male/female connections.

Anyway, perhaps a bit of progress. Might try and see if I have some adapters at home or scrounge some more in e-lab for cabling. I may need local admin rights on the machine at some point but not yet. I’m out of town next weekend but will try and come up some evening this week and do some more work on this.


#6

That yellow cable was supposed to be thrown away already. It is a LapLink cable used to transfer data between PCs from way back in the 90s. It’s not wired straight through and is not the right cable for the job.

You can buy straight through wired 25 pin cables at Fry’s for less than $10 each or I can crimp some with connectors from Tanner Electronics using my Panavise arbor press.


#7

Thanks. I’ve been doing some reading and I think our best bet is to go with the USB to PP converter. I don’t think we’ll need the legacy PP module, which also isn’t technically workable with Win10 anyway. If we do that a longer cable is needed with USB 2/3 type-A male on one end and female on the other. I might have one of those or I know we can get one easily enough.


#8

I a USB extender in hand… I’ll bring it up tonight after the last person leaves my shop and put it in my bin in the galley. It’s in the middle movable section on the bottom row.


#9

I’m surprised that the mach4 was missing. there should have been two shortcuts on the desktop. one for mach4 and one for fusion 360. I have the usb extension, I just forgot to bring it in my hurry to get to class.
The yellow PP cable does belong in the crapper so I’m glad you threw it out.
The main problem (as I saw it) is that m4 did not allow the mapping to occur correctly. while I did see movement on the signals they are in the wrong place. I belive it will be necessary to break this open and do a little rewiring. thanks for taking it over.
-nick


#10

I think we’re aligned guys. I see some options to remap in the software and I’d like to try that first but if we have to crack the case and remap I think we have good documentation and can do so.

I’ll take notes as I go, hopefully good ones :slight_smile:

Edit to add: Reminds me, what are we thinking when it comes to CAM software for the machine? Anyone tried lathe CAM on Fusion 360?


#11

F360 should be good for the cam. We may have to tweak a generic post processor file


#12

@jphelps and I met up tonight by chance and we worked together on the CNC lathe and it’s now working, but not quite ready for prime time as we have two tasks left.

The parallel port USB adapter was incorrectly identified by windows so Jay loaded drivers. Mach4 recognized it but the plug-in for the adapter only allowed for lower pin combinations to be used for motor control so we had to reconfigure the BoB, rewire it, and set the lower pins for inputs instead of outputs. This limits functionality a bit, but the basics are working. I had the wiring right on the BoB and Jay found the problem setting on Mach4 to have the Z control mapped to the proper ‘motor’ setting. Teamwork worked very well and the lathe moves in both the X and Z axis!

Here are the signals to the Parallel Breakout Board (BoB) pin mappings:
X Step = 2
X Dir = 3
Z Step = 4
Z Dir = 5
EStop = 10
X Home = 11
Z Home = 12

The outputs from the control box for the axis switch (X and Z), Step switch (.1, .01, and .001" per step), and the A/B outputs of the turn control are not connected to the parallel port. This means that you can still do local control of the lathe with the controls on the box, but the movements made by doing so are NOT sent back to Mach4, meaning you can get things out of sync if you aren’t careful. This is a limitation of having to remap the wiring on the BoB because of how the USB to Parallel Port adapter allows you to use the pins on the port. It doesn’t allow you to map the motor controls to higher pin numbers so we had to wire them to the lower pin #s and use those as inputs instead of outputs. This leaves us with insufficient outputs to map for those functions.

All the disconnected function wires were labeled and the ends taped. They were then tucked out of the way inside. All of those wires were white teflon coated wires so there were no color codes to document. I noted the changes to the wiring to a sticky note and placed it in the manual on the foldout page where the wiring to the BoB is listed.

We still need to calibrate movements on each axis in Mach4. This will require calipers and telling Mach4 how far something actually moved when it thought it was moving it a specific amount. It will then calculate how far to move to stay accurate so if you want it to move 1" it moves 1". Also, EStop is working, but Mach4 still needs to understand the home switches on the lathe. Once these last tasks are done, it’s ready for prime time!

In the meantime, folks that want to learn how to teach can login and play with it. Next time Jay or I are at the space we’ll calibrate the axis movements and look at the home switch settings.

I think that’s everything - Jay did I forget anything?

Thanks!

Raymond


#13

Great update. We need someone else to log into the machine and validate they see Mach4, can launch the profile “DMS_LATHE” and control the machine. Not urgent but a nice to check off item when someone has a few minutes to try.

Here’s a picture of the box internal and the manual is on the manuals roller cart and contains a LOT of good detail.


#14

you guys are great. thanks!


#15

ANOTHER UPDATE!

Calibrated the motion so that if Mach4 says you moved an inch, you’ve moved an inch. I didn’t calibrate the backlash.

The Home switches are now mapped in Mach4, but it only says that the home switch was tripped. It doesn’t stop moving. Also, I have to check the Z axis switch as it doesn’t drop low enough and oscillates on Mach4.

So, it’s pretty much ready now for folks to play/learn and build teaching modules, but just keep an eye on the stepper motors as they get pretty hot. I need to look at how to reduce the temps. It’s probably something I’ll have to open the top on the box and turn down some current or voltage to the motors with the DIP switches on the driver modules. @richmeyer - do you have any suggestions on that?

Raymond


#16

I do not have the manuals for the stepper drivers with me. I had put a copy of all the manuals in the bound copy of the Instruction Manual that is there at DMS in the roll around bookcase. So you will find the driver manual there and what all the switches do. If I remember correctly it takes 800 steps of the stepper motor to move the axis 0.1 inch, 80 steps to move 0.01 inch, and 8 steps to move 0.001 inch.


#17

Fantastic news. Does anyone know what the Sherline g-code format looks like. I doubt there is a Fusion 360 post processor for the Sherline so I may just have to modify an existing one. I’ll check the Sherline web site to see if there is an example


#18

I set Mach4 to 8000 in the motor section for each axis and when I moved the carriage an inch the calipers said it moved an inch.


#19

@John_Marlow - It’s ready for you to play on. It would be cool to see how tiny and repeatable you could make some of your miniatures with this.


#20

I have found an F360 post processor for the sherline mill/lathe. unfortunately, it is for the LinuxCNC and more broad than we need since the sherline really doesn’t support the full scope of G and M codes. It will take a little effort to redo that. I’ll tackle it as I get time.