RGB LED Light Controllers (Christmas Displays)

Have recently acquired two AlphaPix controllers from HolidayCoro. As a long time user of Light-O-Rama controllers using a proprietary network, these AlphaPix controllers use basic Ethernet networks. I’ve been able to configure them with unique IP address, just can’t get them to “talk” to the RGB light strings.
Curious if there are any DMS members who might have knowledge on setting up these AlphaPix controllers??

These are what I used to make some giant LED walls a while back. Happy to help! Have you tried the built in test patterns? If so, any result at all?

Yes, xLights has a TEST feature under the TOOL menu item… all lights work, but something seem wrong with their addressing… I set Ctrlr1, IPADDR (a subset off the router IPADDR) with the starting universe as 1 with and a count of 20 universes. Ctrlr2, IPADDR with the starting universe as 1 and also a count of 20. I have 4 strings of lights attached as follows: !Ctrlr1:1, !Ctrlr1:9, !Ctrlr2:1, and !Ctrlr2:9 – When I run the test, Ctrlr1 lights 1 and 9 come on and Ctrlr2 lights 1 and 3 come on…!! Lights 1 and 9 on Ctrlr2 should be on but it is light 3 that comes on instead of 9. This has to be an addressing issue but I’m baffled!!

Addressing for these units can overlap and even stagger across outputs. Have you checked your config? Do you have a spread sheet or drawing of your lighting layout? I found google sheets to be invaluable to keep track of addressing (7000+ pixels on my system)

Yep, several times. Right now it isn’t a complicated setup PC -> Network Switch -> Controller (Ethernet/131) -> Prop (1 string of 50 RGB nodes.) Controller can drive 16 RGB strings. I get confused on terminology. I think each of the controller outputs are “ports”? So, to comm with a prop, I need to know what controller -> port -> universe -> pos in universe -> and element (R,G,B) to be energized. I’ve sent a “package” to xLights support and asked them to critique’ it. If I can turn one light on/off on the controller, then I know the path to get to it and can expand from there. Will update this “chat” after I receive their response.

Sounds good. FYI, some softwares start counting at 1, others at 0. My setup at one of each :upside_down_face:

Did not realize I failed to “close” this issue. The problem was a BAD AlphaPix controller. HC replaced it.

1 Like