Pc build no power at all

I’m building a PC and have everything plugged in. No power. Tested the power supply and it is working fine. Replaced the motherboard and still not working. Anyone know computers more than that? I can be at DMS any time tomorrow (Tuesday 26th)

With your tongue?

Using a light bulb?

By holding your hand over the fan?

(Fingers crossed for “using a voltmeter”. :grinning:)


I’d check and make sure the case to MB switch for power on is working with a multimeter (should be short or open depending on the button’s state).

Failing your ability to do that, I’d jumper it with a screwdriver or something conductive (carefully) and see if it powers up.

Haha pretty close. Paper clip. Voltmeter was nowhere to be found.

We tried the screwdriver trick and it did not succeed. :expressionless:

Make really sure you know which pins are which then. If you jumper the wrong pins it won’t work of course.

Outside of that, strip all of the parts (RAM, cards, GPU, CPU etc) off the MB except the PSU cables (You did remember the 4/8 pin for the CPU right?) and try it again. I’d plug a fan into the CPU fan port so you know it’s ON/OFF.

If that fails, RMA the MB because it should power up.

If you want to be really thorough, get a voltmeter and check each voltage rail in the PSU, because the fans on the 12V rail could spin up but the 5V for the CPU rail might not and then it would fail to come on at all.

I can’t find my voltmeter. I’ll bring it up to DMS tomorrow. That’s only other option we have left. We replaced the MB and refuse to believe I picked two bad ones.

Parts list:
CPU: Intel i3-8100
MB: Gigabyte H370M-D3H
GPU: Asus GTX 1060
PSU: Thermaltake Smart 650
Mem: DDR4-2666 8 GB (2x4) Patriot
Case: In Win 707

When you say no power nothing happens and all when you press the power button? Not even a click of the CPU fan trying to start?

Correct. Not a single thing even attempts to start. Might as well be totally unplugged.

Okay that eliminates conductors on your MB being shorted to ground (basically your MB immediately shutting down due to thermal or current limit). Can you take a photo of the setup? No power even with everything but 1 RAM stick in?

In a car right now. Will do when I get home soon.

You can jump the power supply by bridging the green and black with a paperclip, then plugging it in.

If you get no indication of power to anything (lights, GPU leds, etc) either you’ve got something hooked up wrong or the MB is bad. Since you’ve swapped MB, I’m more inclined to believe you’ve missed hooking something up or its not fully seated and it just looks hooked up

Sometimes when I’ve worked on pc’s, every time I’ve plugged everything in I mess up some where and it won’t power up. My suggestion is to remove everything but the video card and drives(if installed) and plug your mouse and KB into the back usb ports on the motherboard, and then try to power it up. if it doesn’t power up you’ll know for sure if its the MB and/or PS. If it does power up, then add a component or two at a time and power it up. You’ll either be done or be able to troubleshoot which part is really giving you a problem.

I hope this helps!

1 Like

Is the cpu seated correctly? What about the bios? How about the ram?

Most boards these days would not boot up if there’s a core component that’s not connected correctly

Update time! I totally forgot to take a picture yesterday. Took it back to Fry’s this morning. The service guy was stumped as well. So I decided one more time to change the MB, but also changed the brand to ASUS.

Worked first time! I ended up buying two dead MB back to back. Installing windows now and all it good. Thanks guys for all the responses. Ridiculous luck.


What brand/model were the bad mobos?

Mentioned above in the HW list.


good chance your i3 is Skylake not coffee lake. Those gigabyte mobos are rated for coffee lake i7.

Like I pointed out earlier. Without the cpu seated right (and that includes the right CPU) your PC will not boot up to post (ie bios/UEFI). just never going to happen.

Always check the compatible of chip sets by comparison of serials and socket types. Tom’s hardware has updated guides all the time.

gigabyte is usually a solid brand! I’m surprised but happy you got it taken care of! Good Job!!!

Ahh, the good old we change sockets every 6 months, but that’s still not fast enough so we break compatibility even if it fits in the socket.

AM3 hasn’t done me wrong in the last 8 years. I guess it’s time to upgrade AM4.

1 Like