2005 Mercury Monterey (aka Freestar) Van foo

The setup

I was going to take this on an overnight trip Friday. It was last run last Sunday. I got out to start it and the battery was pretty hard flat - under 6V. I put a little charge on it and it started right up - with the check engine light on. I plugged in my cheap wifi dongle ODBII interface and freebie software and it won’t connect to the ECU. It worked fine in the past. Gave up and took another vehicle.

The Symptom

Got back today, and the battery was flat again. Charged it for a while and it started ticking every second or two. Disconnected the battery and let it charge for an hour - and left the vehicle disconnected for that time. Connected the battery back up and it started ticking again. Isolated the ticking to the indicated housing on the intake. Unplugged and the ticking went away. Vehicle won’t start with it disconnected, but when connected starts, but seems to have a little trouble idling.

I believe this beast is throttle body injection, this is the throttle body butterfly, and that the issue is likely a dead sensor. I have the Ford shop manuals and will dig through them tonight. I plan to come to DMS and try and read the ECU codes tomorrow (Sunday.) Hopefully the Autel will do the deed and be enlightening.

I want to take this on a long trip in a month, so I need to get it stable pretty soon. Probably need a battery as well given the abuse it’s gotten.

I’ll take and appreciate any advice I can get.


I think that’s the Idle Air Controller. I think when they go bad, they go bad. As they have moving parts to adjust idle speed by allowing air to bypass the throttle plate, they’re subject to wear-out more so than solid state sensors. Ya never know, tho.

This guy talks too much, but seems to be pointing at the same part on a slightly different engine, if it helps any, and is going to put a new one on.

1 Like

PS last car sold in the USA with throttle-body injection was the 2000 Geo Metro.
Ford started with multipoint in 1986 or so, and never really looked back, as far as I know.

That is what in my world would have been called an “ISV” but the ass backward rest of the world called it an “IAC Valve” or similar(Idle air control valve - for those that were the last to bring fuel injection to the masses)

1 Like

Since the valve is ticking even when the key isn’t in the ignition, I’m thinking not valve, but ECM or bad sensor. I actually don’t see how it could be anything but the ECM. I need to look at the wiring diagrams and see if the ECM has power in the off position.

1 Like

Engine should start with the idle valve unplugged. -may not idle well but should start.

Does not start with it unplugged. Just cranks.

1 Like

My cheapie Bosch code reader was able to get some data from ODBII port, but it’s pretty bogus. U1059, U1027, U1073, U1009, C1288. This is beginning to look like my old friend Ford TSB 06-14-10 - “Water in the Powertrain Control Module Connector.”

I’ll have to dig into it which requires a bit of disassembly to get to the connector. Hopefully it’s just the connector and not the module proper.

1 Like

have you tried the Autel at the DMS?

I have in the past but not this go round.

I’d like to, but I’m reluctant to drive it the half hour required in this condition. I’ll tear into it next Saturday and see what I can learn.


I just became aware of the ProDemand auto repair website that Makerspacers have access to. It also works on the “Jump” remote server so you can see it from home. I am working through some check engines on my vehicles with it. BTW what is Autel?

1 Like


1 Like

I am hoping for a future “next Saturday or Sunday” for a very early start to remove the stink eye from the other half - by completing long overdue required maintenance…I think May will be a good month to remove the sub-frame, maybe even this may!