Unable to Add Class

Hello all!

I am trying to teach a class on the 15th for extracting and quantifying plasmid DNA from E.Coli, but when I click submit I get the following error. I would appreciate any help so that I may help educate other makers with a cool hands-on activity. BTW I am a member, I just have not gotten the green dot back yet.

1 Like

Huh. I think @Team_Calendar is the go-to. My suggestions might be unhelpful, so I’m keeping my mouth shut. (Sort of “did you turn it off and on again” level of helpful.)

1 Like

Wow…that list is rather out-of-date.

1 Like


You’re quite classy.

1 Like

My bet is on expired login.
Suggest composing all fields offline, login, copy, paste, submit to avoid this.
Obviously, I could be wrong…


I just tried that to no avail; it threw the same error. Thank you for the idea though.

@Team_Infrastructure any ideas? Beyond expired login session I don’t know why I’d see a CSRF issue.

I just tried doing it again, then one more time on Microsoft Edge instead of Firefox. Same error. Still no clue how to resolve this issue.

Perhaps some permission issue exists on the member database with my account. I had my account transferred from a family member one to an individual one. Maybe something did not get set up completely right.

shouldn’t be. Permission errors would just give you a failed login, not a CSRF error.

That’s what makes it a weird.

Sounds like a compromised pc. Do you have antivirus etc?

What makes you think this is a compromised PC?

Several company help sites recommend trying this. Seems simple safe and maybe worth a try.

  • Try refreshing the page where you saw the error. Some shortcut keys for doing a hard or forced refresh.

Windows: ctrl + F5
Mac/Apple: Apple + R or command + R
Linux: F5

  • Clear cached memory

To ensure you see the latest version of a site you need to clear the cache memory. Sometimes, a simple hard refresh won’t work and you need to clear the cache by hand. On this site you can find step by step guides for Chrome, Firefox 3, Firefox 2, Internet Explorer 8, Internet Explorer 7, Internet Explorer 6, Safari and more on how to refresh your cache.

  • Restart your browser.

From: https://intercom.help/keen/en/articles/22008-what-is-csrf-token-error

I got it to work! None of the suggested solutions worked, but by not adding the PowerPoint presentation to the event it worked. Interestingly, when I went to then edit the event and add the PowerPoint, it gave me a very similar error (after submitting the change). IF YOU RUN INTO A SIMILAR ERROR, I WOULD SUGGEST NOT ADDING ANY ADDITIONAL FILES TO THE CALENDAR SUBMISSION
At least, that is what worked for me. I will post another thread with more details on the class soon!