Problems with TSOP1100 Wide band IR receiver


#1

So I bought a Zune remote at Tanner’s to use with a project, of course there is no datasheet for it, so I was going to use a wide-band receiver with an arduino to figure out the frequency and map the buttons, but I can literally get NOTHING from this receiver. I connected the pins per Datasheet, vss,grnd, and signal, but I get nada. Any ideas? I tried many remotes, none of them (which I know are working remotes) seem to register.


#2

I tried a pullup resistor too, between vss an signal, still no love.


#4

Can you post a picture of it?


#5

https://www.google.com/amp/s/www.digchip.com/datasheets/parts/datasheet/513/TSOP1100_amp.php


#6

I thought you said it was a zune remote …


#7

https://www.ebay.com/p/Authentic-Zune-Model-1130-Remote-Control/1317621335


#8

One of the quick ways to check if an IR remote is working is to point it at your phone camera and see if it shows up as a blinking led. Phone cameras generally can see IR at least from remotes. You can check yours with another remote.


#9

yeah, I have an IR camera. The remotes all work, I just can’t get my IR TSOP 1100 to receive a signal.


#10

What you might try is hooking up another receiver taped to it or even another IR Led and that to an oscilloscope and see what you get. It may work differently than you expect. It is Microsoft. :stuck_out_tongue:


#11

Yeah, my problem is I don’t know how to use an oscilloscope yet.


#12

#13

293 votes and 18 comments so far on Reddit

https://www.reddit.com/r/electronics/comments/aphhge/an_ir_value_tester_i_made/


#14

That’s what I was trying to build - minus the LCD, but I couldn’t get a response from the TSOP1100. I was using the same libraries as him. Code runs great, I just don’t receive anything. I haven’t looked at it in a week or 2. I’ll get back to it when I have some time. It’s not at the top of my list.