New Display Monitor Locks/Times Out Too Fast

I hooked up a new monitor last week…my old monitor behaved just fine/as I intended. It was connected via a DVI-D cable. My new monitor is an Acer SB220Q connected via a HDMI cable (O/S is Windows 10, 64-bit, Home Edition).

My display now locks after exactly 1 minute of inactivity and blacks out after about 2 minutes. The monitor does not seem to have any adjustments/buttons that affect this behavior. Despite the relevant settings being set to what I want (“Power & Sleep”: screen = 20 minutes; sleep = 30 minutes) and double-checked in Control Panel\All Control Panel Items\Power Options\Edit Plan Settings, then rebooted, the undesired behavior continued.

I have done a bunch of interneting and followed a few troubleshooting guides that included switching drive back to the “Generic PnP Monitor” driver and changing some registry key values for “power plan” related keys…no luck, although it became clear that when I turned some of the keys on so that they displayed in the Settings panels, they were all defaulted to 1 minute, so that probably means something.

So, anyone have a similar experience? Or troubleshooting suggestion? While the only real difference between my old and new monitors is their connection (DVD-I vs. HDMI) I didn’t find any references to other registry tweaks for this?

I know you mentioned the power settings in Control Panel but have you tried messing around with the Windows 10 Settings? Namely the Power & Sleep tab under the System section:

Yes, I directly reference this in OP.

My apologies, I overlooked the Power & Sleep settings you had set. What GPU are you using?

No worries… :–)

Nvidia GeForce GTX 1660 Ti

Not sure if this is a rabbit hole you’ve gone down or not. I don’t have this monitor to test, so here goes an armchair theory.

From your manual, this monitor has its own power save feature:

Now I don’t see any way to affect it directly, but have you checked the DCC/CI is set to “ON”?

That SHOULD make it read the settings from Windows rather than on board.

2 Likes

That’s new info…I’ll check/try it!


edit: no joy :–(

1 Like

I’ve used this registry edit before to prevent the display from powering off after the session has been locked. Maybe try setting it to something higher to see if it changes anything. Note this is hidden by default. The registry edit is required to expose the setting.

Same for the lockout timer. It might be worth trying changing the registry key directly. It’s possible the value has been corrupted to set to an invalid value.

Maybe search for different guides before implementing these. I didn’t try these exact guides.

1 Like

Just what we need… the start-stop pandemic jumps from motor vehicles to computer monitors…

Whatever it is, still no luck. I can’t believe I have to return a monitor because I can’t adjust/change the display timeout…sigh.

1 Like

I’d try a divide and conquer approach: if you move the monitor to a different PC, does the behavior follow? If you attach a similar brand monitor to the original PC, does that monitor also sleep?

Might help determine if it is a monitor or an o/s + driver issue.

3 Likes

I’d also try a different input on the monitor. Some of ours at work behave differently if you use HDMI versus DisplayPort. It’s maddening.

1 Like

Agreed, this describes the correct, rigorous approach…if everything was that simple. But I don’t have another monitor; and I don’t have another computer with the same operating system. The monitor I did have (before it failed and caused me to buy this one) worked just fine with the current PC/OS in question. Per above, the only real difference (other than the new monitor is a different brand and whatever else on the inside) is that it is hooked up with HDMI vs. whatever I had used with the last monitor, which I think I used an SVGA cable, but anyway, it got tossed with the failed monitor as it did not have a spot to connect to on this one.

But anyhoo…I think I’ll purchase a different cable (DVI-D, SVGS, whatever) and connect the current monitor with it and see if that cures anything….a bit of a long shot, but easies short term dink I can think of.

Turns out it was the screen saver setting. I have never used a screen saver, preferring the screen just to go dark. Somehow, and I don’t understand how, either installing new driver or simply switching to HDMI for control did something, or possibly Windows Update did something that was coincident in time with my new monitor being hooked up, or HDMI controller signals handle that setting different than VGA, or…? Anyhoo…mischief managed, case solved, mission accomplished, cookie crumbled, drop the mike, over and out!

7 Likes