MPCNC help. Zig zagging instead of following plot

A while back, I built an MPCNC, but then life happened (baby). It has sat on the back burner ever since…
I ran into a few issues back then, and I was hoping to resurrect it again soon. Any help would be awesome! My timing for this project, once again, sucks. We’re expecting our second kiddo any day :slight_smile:

So, I successfully engraved a small tree from a vector file… once. After that, when I run a file, it seems to work at first, then starts zig zagging from lower left to upper right. I think I messed up a setting somewhere, but just not sure where. I was using ESTLCAM on two different computers, and maybe something happened there… My machines are definitely old and slow.
I’ve also not been terribly happy with the workflow: ESTLCAM for file creation and Repetier-host to run the files. Could simply be the performance of the computers, but if someone has a different workflow, I’d love to hear it.

@Chris_Wischkowsky, @Clayton, and @JohnK, you guys were very helpful when I was initially working on this. Any insight?

1 Like

I may not have been the Clayton you int red to call on…that said, I have been planning to build my MPCNC! It’s in the list…hopefully I’ll finish all my existing projects to start it by June 15 :wink:

haha! I know… projects are like bunnies. Can’t leave them alone or…

Yeah, you were on the initial thread :slight_smile: If I get things up and running, I’ll let you know how it goes :slight_smile:

Coolio. Did you print your pieces? Or bring them in premade?

My MK3 goes through bouts of being intolerable…that’s its current state. It’s one of the projects to finish so I can move on with others. I hear it takes a couple of weeks to print all the pieces, and I have been unable successfully print PETG, only PLA seems to work.

I printed my own in PLA. Took a week or two. I made a spreadsheet to keep track of what parts print in what color and quantity, and I used two folders for each color. One folder was gcode files that needed to be printed, and another was files that had successfully printed. I did it on an uber cheap ANET A8 knock off, so you should be golden with PLA on an MK3 :slight_smile:

What controller is yours built on?

I built a TopsCNC that I am using an Arduino CNC shield and grbl to run. My workflow has been using Easel to export the Gcode and then CNCJS to run it.

1 Like

Hey Matt,
I almost started a MPCNC, then I went down a few rabbit holes on https://www.reddit.com/r/hobbycnc/ and https://www.reddit.com/r/diycnc/ where people were comparing different kits. I think I’ll end up going with https://threedesign.store/ (after looking at MPCNC, RSCNC-32, and finally PrintNC), but those subreddits might be good places to get some help as well? They’re inspiring at times regardless :slight_smile:

For now, maybe it makes sense to write the G-Code by hand for testing just to rule out any oddities with the CAM portion? Some G-Code that just does some simple squares might make sense to try out?

If you get a chance, take a picture of what’s going on as it might help as well?

Why did you choose PLA vs PETG?

I’m using the kit that v1engineering offers on their site. Pretty sure it’s the Rambo 5 board.

@Kentamanos Thanks for the leads! I’ll check them out for sure :slight_smile: Cost was a big factor in my decision, and if I can get this working, I may build his LowriderCNC kit :slight_smile: Would be dang cheap for that level of accuracy and size of workspace! I’ll see if I can get the original tree file to print. If so, maybe I can compare the code. If not, I’ll give writing the code manually a shot.

@Clayton 2 reasons. 1: He lists it as a viable material and 2. It’s what my cheap printer will print :stuck_out_tongue_winking_eye:

You used two different computers to generate the GCODE and think maybe settings where off? Can you simulate the run of each and do they both run in sim properly?

1 Like

That’s correct. Can I use Repetier to sim? I‘be only done sim on vcarve. I’m also yet to get Repetier to show me a preview.

I don’t recall if Repetier can do so but there are a lot of simulators available. I can’t recommend anything in particular but here’s one that’s online even: https://ncviewer.com/

You could also do a DIFF of the two files and see what’s different. Presumably if everything was the same differences would be small.

I’d be thinking something mechanical or electrical could be the issue however I’d only think that if the system failed repeatedly in the same fashion which I didn’t infer from your earlier post. If you run File A and it works and File B always fails at the same point in the same way I’m thinking GCODE …

Good luck!

Thanks for all you guys input! It led me down the rabbit hole to find a single unchecked box in Estlcam. Running like a champ. If I make anything with it soon, I’ll post it

2 Likes