Mars 2 Pro: Unknown File Format

After successfully printed on the Elegoo Mars with .cbddlp files generated from the Chitubox on workstation 3dfab-05, I tried to use the Elegoo Mars 2 Pro. First, it said my .cbddlp file was in Unknown File Format. Then, I added a new machine in Chitubox Settings and printed out a .ctb file. But I still got Unknown File Format.

Anyone know how to give it a good format?

There are two workstations in 3D Fab that have the Chitubox slicer (green arrows). I don’t know which one is 3dfab-05. The slicers are different versions (which is actually a good thing because the firmware on the resin printers varies).

Try creating a .ctb file on the other workstation. I routinely have the problem you’re describing. One slicer works with one printer, and the opposite for the other one. I don’t remember which is which.


@engpin … please do not update the slicer that is still version 18. I think that’s on the south workstation.

Thanks for the info. 3dfab-05 is the most distant one from the Elegoo machines. I found Chitubox.exe in its /Program Files directory and its Default setup generates a .cbddlp file that works on the Elegoo Mars but not the Elegoo Mars 2 Pro. I have used 3dfab-02 (the one closest to the Elegoo machines) to generate a .cbddlp file that works on the Elegoo Mars.

I will try to use 3dfab-03 (the second closest to the Elegoo machines) to print on Elegoo Mars 2 Pro next time.

Just as a curiosity, why are you not using .ctb files?

BTW, 3D Fab doesn’t have a Mars 2 Pro. 3D Fab has a Mars Pro and a Mars 3. That could also account for issues if you’re slicing it for a Mars 2 Pro.

Chitubox saves the sliced files in .cbddlp by default on the workstations I used.

I didn’t have an icon on my desktop when I logged on and ran the newest version of Chitubox.exe in c:\Program Files. Perhaps you guys have access to some existing profiles that save them in .ctb. If this is the case, the training class should mention how to get them.

Yah, I remember being frustrated that I frequently can’t find Chitubox on those computers either.

Did you have to log in to Chitubox to use it? I don’t remember if that’s necessary. Was there already a machine set up, or did you have to set it up?

Chitubox says the way to fix this problem is to recreate the printer profile and it should save to ctb thereafter. I don’t know if the printer profile is unique to each user or set to the machine. I’ve used both of those computers to slice on Chitubox and AFAIK I’ve never generated a .cbddlp file.

OK, problem solved.
I got their machine types from labels on the back of Mars Pro (the smaller one) and Mars 3 (the bigger one). Created each machine in my own Chitubox profile. Then, generated 2 different .ctb files. It is common practice to embed a header in this kind of binary files to iditify the target machine. They are different. That’s why I got Unknow File Format yesterday when I didn’t use the correct machine type when slicing.

I would suggest adding a screenshot for Mars 3 in the Slicing section of the training material to remind users that there are different machine types and they need different preparations.