Fusion 360 scaling to DXF

I noticed some interesting quirks when exporting from Fusion360 to dxf.

First - the sketch needs to be on the XY plane. I have my F360 set up with Z-axis pointing up like conventional machining. The dxf exporter doesn’t like that - it exports from the perspective of the XY plane (so it was exporting just a single line because it was looking at my sketch from the side).

Second - I had problems with scaling. Regardless of whether my document units were inches or millimeters, the exported file was exactly 2.54x the correct scale when using the File/Export protocol.

However, when I right-clicked on the sketch and exported just the sketch to dxf, that was correctly scaled.

Anyone else have similar issues? @malcolmputer, @TBJK, @nicksilva - have you seen this? If it’s just operator error, I’d appreciate any suggestions.


How are you exporting the DXF?
I found some sort of scaling issue myself when I exported from the main body to a STL.

Traditionally I create DXF from the sketch directly. IE right clicking on the sketch in the left plane where you can disable/enable items.

DXF’s have no units in the actual file. So it’s partially “what did it use for units going out when it wrote out those values” and “what does 1.0 mean when I import this” in another application. It’s a super huge PITA.

I’ve had stuff export from Inkscape with font points as units. No amount of dividing by or multiplying by 25.4 or 2.54 would ever fix that problem. :slight_smile:


I exported the other day on F360 to dxf for my first time. Completely came out wonky - wrong view. I suspect this has to do with your note on exporting only the XY perspective. I had no idea.

In the meantime, I looked up how to export dxfs, and the solution was exactly as you mention: “[right-click] on the sketch and export” to dxf.

I haven’t had time to get back to my project, but it definitely sounds like I’m going to be right-clicking on the sketch to export.


I had exactly the same experience you did. Scaling problem when exporting from main body. Right click sketch to dxf works correctly.

1 Like

Mind you, I didn’t find this documented somewhere by an expert. It’s just what I observed. Might not be 100% accurate … YMMV.


Compounded by the fact that InkScape changed the points per unit during one release (from 80 to 96 IIRC). It made importing InkScape into Adobe make things 1.2 times as big as well. Close enough to cause me to waste some leather.

This works well for most uses. The problem I’m run into is poor handling of certain sketch elements, like construction lines. Often, there are extraneous lines and even double lines

The other option on exporting is creating a new sketch from a face. Extrude your sketch so you have the exact elements you want. Then select the face of the object you wish and create a new sketch off that.

Doesn’t solve the sizing issue. DXF Is a stupid format.