Big Thunder's Lightburn Default

Anyone who uses the computer next to Big Thunder and pulls up lightburn has probably noticed that for some reason, someone has decided to add all 3 of the laser cutters to the Lightburn installation, and that it defaults to Donner for reasons completely unknown.

If anyone knows how to stop the big thunder’s computer from defaulting to trying to send all of the jobs you upload on it to donner and stay fixed, please let me know. Even when I remove Donner and Blizen’s information from Lightburn’s Device manager, once you close and reopen the program they’ve come back, and Donner has been reassigned default. This is true no matter who logs into the computer, including multiple people who I’ve taught laser to who have never used the computer before. I’d like to fix it for good because it’s leading to a lot of confused laser beginners.

1 Like

@skyspook wrote a script that adds the lasers to Lightburn automatically to try and avoid confusion when we switched to ethernet.

Perhaps we can set the default on a per computer basis, or just modify the script to only add the applicable laser.

Script never worked, but there is a default file for lightburn. Sounds like it just needs to be tweaked. I’ll do it next time I’m in, but if someone else wants to give it a go, it should just be in the lightburn program folder.

In lightburn you can change the default device pretty easily. Just click the Devices button and then choose the one you want as default. It worked for me at least.

It reverts itself once you’ve closed lightburn. Plus, most people don’t know how to do that and it doesn’t make any sense for us to say “everyone who is ever going to use this needs to learn this extra step that you need to do every time” when the alternative is ‘let’s just fix the problem’

That sounds like something external, like a script. I see above it didn’t work but perhaps it’s still lingering and mucking things up?

We’re using a default function of LightBurn that allows a default preferences file to auto-set some things (like IP addresses and settings for each laser) on startup (

I believe we just included all 3 lasers in the default file, which is why it’s causing confusion (made sense at the time we did it, but time lets us learn). It’s just a file called defaultprefs.ini in the main program folder, but I believe you’d need admin access to change it. I’ll see if I can remote in later, else I’ll change the file next time I’m in – sometime in the next week.

1 Like

I just checked today during my class. It’s still behaving the same way. I can take a look at the default file here in a minute, see if I can make something work there.

I got a second to look at the file. It looks like it’s probably the culprit, but someone was actively using the computer at the time to work on Blitzen and I didn’t feel comfortable kicking them off in the middle of a job to mess around with it. I’ll give it another look next time I’m up here.

1 Like

I should be in tomorrow for a few hours. I’ll try to grab it if it’s not in use.

Preferences have been updated. May need to start lightburn twice for it to take effect